/bugzilla3/ Bug 736 – [IPF-VTI] Creating VTI domain will meet "Cannot allocate memory"
Bug 736 - [IPF-VTI] Creating VTI domain will meet "Cannot allocate memory"
: [IPF-VTI] Creating VTI domain will meet "Cannot allocate memory"
Status: RESOLVED FIXED
Product: Xen
HVM
: unstable
: IA64 other
: P2 normal
Assigned To: Xen Bug List
:
:
:
  Show dependency treegraph
 
Reported: 2006-08-10 23:48 CDT by Yongkang You
Modified: 2006-10-18 22:01 CDT (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yongkang You 2006-08-10 23:48:56 CDT
Environment:
------------
Service OS (ia32/ia32e/IA64): RHEL4u3 IA64
Guest OS (ia32/ia32e/IA64): RHEL4u3 IA64 VTI
Change Set: 10937
Hardware: Tiger4
physical memory: 8G
domain0 mem: 1G
Guest mem: 2G
domain0's sched: bvt

Bug detailed description:
--------------------------
With creating and destroying a 2G memory VTI domain a lot of times (should >5
times), I will meet this issue. Control Panel will report "Cannot allocate
memory" and refuse to create VTI domain.

But if I continue to try to recreate VTI domain for several times, finaly the
VTI domain can be created successfully. So strange~


Reproduce steps:
----------------
1. create 2G memory VTI domain 
2. after it is up, destroy it.
3. redo step 1 and step 2 for several times.
4. meet the creating failure issue.
5. if retrying create several times, VTI domain can be up again.
Comment 1 Hiroya INAKOSHI 2006-08-25 04:22:02 CDT
Situation is the same on Domain-U.

I found that copy_from_guest in do_mem_op@xen/common/memory.c failed
and returned a non-zero value.  'xm create' reports 'Cannot allocate
memory' because of this non-zero value.

Please see "[Xen-ia64-devel] [PATCH][RFC] copy_from/to_guest" and its
follow ups.

http://thread.gmane.org/gmane.comp.emulators.xen.ia64/3726/focus=3726

When xencomm is ported to ia64, the porting patch will get rid of this problem,
too.
Comment 2 Yongkang You 2006-10-18 18:09:43 CDT
should has been fixed, as didn't see it for a long time.
Comment 3 Yongkang You 2006-10-18 22:01:06 CDT
Fixed in xen-ia64-unstable changeset: 11720