/bugzilla3/ Bug 611 – Guest domain does not come up - Invalid Argument 22
Bug 611 - Guest domain does not come up - Invalid Argument 22
: Guest domain does not come up - Invalid Argument 22
Status: RESOLVED FIXED
Product: Xen
Guest-OS
: 3.0 (general)
: x86 All
: P2 normal
Assigned To: Xen Bug List
:
:
:
  Show dependency treegraph
 
Reported: 2006-04-11 07:50 CDT by Joe Thykattil
Modified: 2006-04-21 12:41 CDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joe Thykattil 2006-04-11 07:50:00 CDT
Attempting to bring up a guest domain, but get the following error:

# xm create -c /etc/xen/cartman
Using config file "/etc/xen/cartman".
Error: Error creating domain: (22, 'Invalid argument')
# 

# xm create -c /etc/xen/cartman
Using config file "/etc/xen/cartman".
Error: Error creating domain: (22, 'Invalid argument')
# cat /etc/xen/cartman
kernel = "/boot/vmlinuz-2.6.15-1.2054_FC5"
name = "cartman"
memory = "256"
disk = ['file:/testing/cartman/disk1,sda1,w']
extra = "ro selinux=0 3"
# 

# uname -a
Linux labxen1 2.6.16-1.2080_FC5xen0 #1 SMP Tue Mar 28 04:13:51 EST 2006 i686

System is an HP DL-360 with 2 Gigs of RAM.

Please advise.

Thanks,

Joe
Comment 1 Joe Thykattil 2006-04-11 07:53:09 CDT
xm dmesg:

 Xen version 3.0.0 (bhcompile@build.redhat.com) (gcc version 4.1.0 20060304
(Red Hat 4.1.0-3)) Tue Mar 28 03
:35:03 EST 2006
 Latest ChangeSet: unavailable 

(XEN) Physical RAM map:
(XEN)  0000000000000000 - 000000000009f400 (usable)
(XEN)  000000000009f400 - 00000000000a0000 (reserved)
(XEN)  00000000000f0000 - 0000000000100000 (reserved)
(XEN)  0000000000100000 - 000000009fffa000 (usable)
(XEN)  000000009fffa000 - 00000000a0000000 (ACPI data)
(XEN)  00000000fec00000 - 00000000fec10000 (reserved)
(XEN)  00000000fee00000 - 00000000fee10000 (reserved)
(XEN)  00000000ffc00000 - 0000000100000000 (reserved)
(XEN) System RAM: 2559MB (2621028kB)
(XEN) Xen heap: 10MB (10268kB)
(XEN) Using scheduler: Simple EDF Scheduler (sedf)
(XEN) PAE disabled.
(XEN) found SMP MP-table at 000f4fd0
(XEN) DMI 2.3 present.
(XEN) Using APIC driver default
(XEN) ACPI: RSDP (v000 COMPAQ                                ) @ 0x000f4f70
(XEN) ACPI: RSDT (v001 COMPAQ P31      0x00000002 Ò 0x0000162e) @ 0x9fffa000
(XEN) ACPI: FADT (v001 COMPAQ P31      0x00000002 Ò 0x0000162e) @ 0x9fffa040
(XEN) ACPI: MADT (v001 COMPAQ 00000083 0x00000002  0x00000000) @ 0x9fffa100
(XEN) ACPI: SPCR (v001 COMPAQ SPCRRBSU 0x00000001 Ò 0x0000162e) @ 0x9fffa1c0
(XEN) ACPI: DSDT (v001 COMPAQ     DSDT 0x00000001 MSFT 0x0100000b) @ 0x00000000
(XEN) ACPI: Local APIC address 0xfee00000
(XEN) ACPI: LAPIC (acpi_id[0x00] lapic_id[0x00] enabled)
(XEN) Processor #0 15:2 APIC version 20
(XEN) ACPI: LAPIC (acpi_id[0x02] lapic_id[0x02] disabled)
(XEN) ACPI: LAPIC (acpi_id[0x04] lapic_id[0x04] disabled)
(XEN) ACPI: LAPIC (acpi_id[0x06] lapic_id[0x06] enabled)
(XEN) Processor #6 15:2 APIC version 20
(XEN) ACPI: LAPIC (acpi_id[0x01] lapic_id[0x01] enabled)
(XEN) Processor #1 15:2 APIC version 20
(XEN) ACPI: LAPIC (acpi_id[0x03] lapic_id[0x03] disabled)
(XEN) ACPI: LAPIC (acpi_id[0x05] lapic_id[0x05] disabled)
(XEN) ACPI: LAPIC (acpi_id[0x07] lapic_id[0x07] enabled)
(XEN) Processor #7 15:2 APIC version 20
(XEN) ACPI: LAPIC_NMI (acpi_id[0xff] dfl dfl lint[0x1])
(XEN) ACPI: IOAPIC (id[0x02] address[0xfec00000] gsi_base[0])
(XEN) IOAPIC[0]: apic_id 2, version 17, address 0xfec00000, GSI 0-15
(XEN) ACPI: IOAPIC (id[0x03] address[0xfec01000] gsi_base[16])
(XEN) IOAPIC[1]: apic_id 3, version 17, address 0xfec01000, GSI 16-31
(XEN) ACPI: IOAPIC (id[0x04] address[0xfec02000] gsi_base[32])
(XEN) IOAPIC[2]: apic_id 4, version 17, address 0xfec02000, GSI 32-47
(XEN) ACPI: IOAPIC (id[0x05] address[0xfec03000] gsi_base[48])
(XEN) IOAPIC[3]: apic_id 5, version 17, address 0xfec03000, GSI 48-63
(XEN) ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 high edge)
(XEN) ACPI: IRQ0 used by override.
(XEN) ACPI: IRQ2 used by override.
(XEN) Enabling APIC mode:  Flat.  Using 4 I/O APICs
(XEN) Using ACPI (MADT) for SMP configuration information
(XEN) Initializing CPU#0
(XEN) Detected 2399.393 MHz processor.
(XEN) CPU: Trace cache: 12K uops, L1 D cache: 8K
(XEN) CPU: L2 cache: 512K
(XEN) CPU: Physical Processor ID: 0
(XEN) Intel machine check architecture supported.
(XEN) Intel machine check reporting enabled on CPU#0.
(XEN) CPU0: Intel P4/Xeon Extended MCE MSRs (12) available
(XEN) CPU0: Thermal monitoring enabled
(XEN) CPU0: Intel(R) Xeon(TM) CPU 2.40GHz stepping 09
(XEN) Booting processor 1/1 eip 90000
(XEN) Initializing CPU#1
(XEN) CPU: Trace cache: 12K uops, L1 D cache: 8K
(XEN) CPU: L2 cache: 512K
(XEN) CPU: Physical Processor ID: 0
(XEN) Intel machine check architecture supported.
(XEN) Intel machine check reporting enabled on CPU#1.
(XEN) CPU1: Intel P4/Xeon Extended MCE MSRs (12) available
(XEN) CPU1: Thermal monitoring enabled
(XEN) CPU1: Intel(R) Xeon(TM) CPU 2.40GHz stepping 09
(XEN) Booting processor 2/6 eip 90000
(XEN) Initializing CPU#2
(XEN) CPU: Trace cache: 12K uops, L1 D cache: 8K
(XEN) CPU: L2 cache: 512K
(XEN) CPU: Physical Processor ID: 3
(XEN) Intel machine check architecture supported.
(XEN) Intel machine check reporting enabled on CPU#2.
(XEN) CPU2: Intel P4/Xeon Extended MCE MSRs (12) available
(XEN) CPU2: Thermal monitoring enabled
(XEN) CPU2: Intel(R) Xeon(TM) CPU 2.40GHz stepping 09
(XEN) Booting processor 3/7 eip 90000
(XEN) Initializing CPU#3
(XEN) CPU: Trace cache: 12K uops, L1 D cache: 8K
(XEN) CPU: L2 cache: 512K
(XEN) CPU: Physical Processor ID: 3
(XEN) Intel machine check architecture supported.
(XEN) Intel machine check reporting enabled on CPU#3.
(XEN) CPU3: Intel P4/Xeon Extended MCE MSRs (12) available
(XEN) CPU3: Thermal monitoring enabled
(XEN) CPU3: Intel(R) Xeon(TM) CPU 2.40GHz stepping 09
(XEN) Total of 4 processors activated.
(XEN) ENABLING IO-APIC IRQs
(XEN) ..TIMER: vector=0x31 apic1=0 pin1=2 apic2=-1 pin2=-1
(XEN) checking TSC synchronization across 4 CPUs: passed.
(XEN) Platform timer is 1.193MHz PIT
(XEN) Brought up 4 CPUs
(XEN) Machine check exception polling timer started.
(XEN) mtrr: your CPUs had inconsistent fixed MTRR settings
(XEN) mtrr: probably your BIOS does not setup all CPUs.
(XEN) mtrr: corrected configuration.
(XEN) *** LOADING DOMAIN 0 ***
(XEN) Domain 0 kernel supports features = { 0000001f }.
(XEN) Domain 0 kernel requires features = { 00000000 }.
(XEN) PHYSICAL MEMORY ARRANGEMENT:
(XEN)  Dom0 alloc.:   03000000->04000000 (610553 pages to be allocated)
(XEN) VIRTUAL MEMORY ARRANGEMENT:
(XEN)  Loaded kernel: c0100000->c0455b7c
(XEN)  Init. ramdisk: c0456000->c081fc00
(XEN)  Phys-Mach map: c0820000->c0a783e4
(XEN)  Start info:    c0a79000->c0a7a000
(XEN)  Page tables:   c0a7a000->c0a7e000
(XEN)  Boot stack:    c0a7e000->c0a7f000
(XEN)  TOTAL:         c0000000->c0c00000
(XEN)  ENTRY ADDRESS: c0100000
(XEN) Dom0 has maximum 4 VCPUs
(XEN) Initrd len 0x3c9c00, start at 0xc0456000
(XEN) Scrubbing Free RAM: ..........................done.
(XEN) Xen trace buffers: disabled
(XEN) *** Serial input -> DOM0 (type 'CTRL-a' three times to switch input to
Xen).
Comment 2 Joe Thykattil 2006-04-11 07:54:36 CDT
tail /var/log/xend.log:

[2006-04-11 09:37:32 xend.XendDomainInfo] DEBUG (XendDomainInfo:177)
XendDomainInfo.create(['vm', ['name', '
cartman'], ['memory', '256'], ['vcpus', '1'], ['image', ['linux', ['kernel',
'/boot/vmlinuz-2.6.15-1.2054_FC
5'], ['args', 'ro selinux=0 3']]], ['device', ['vbd', ['uname',
'file:/testing/cartman/disk1'], ['dev', 'sda
1'], ['mode', 'w']]]])
[2006-04-11 09:37:32 xend.XendDomainInfo] DEBUG (XendDomainInfo:283)
parseConfig: config is ['vm', ['name', 
'cartman'], ['memory', '256'], ['vcpus', '1'], ['image', ['linux', ['kernel',
'/boot/vmlinuz-2.6.15-1.2054_F
C5'], ['args', 'ro selinux=0 3']]], ['device', ['vbd', ['uname',
'file:/testing/cartman/disk1'], ['dev', 'sd
a1'], ['mode', 'w']]]]
[2006-04-11 09:37:32 xend.XendDomainInfo] DEBUG (XendDomainInfo:379)
parseConfig: result is {'ssidref': None
, 'uuid': None, 'on_crash': None, 'on_reboot': None, 'image': ['linux',
['kernel', '/boot/vmlinuz-2.6.15-1.2
054_FC5'], ['args', 'ro selinux=0 3']], 'on_poweroff': None, 'cpus': None,
'name': 'cartman', 'backend': [],
 'vcpus': 1, 'cpu_weight': None, 'vcpu_avail': None, 'memory': 256, 'device':
[('vbd', ['vbd', ['uname', 'fi
le:/testing/cartman/disk1'], ['dev', 'sda1'], ['mode', 'w']])], 'bootloader':
None, 'cpu': None, 'maxmem': N
one}
[2006-04-11 09:37:32 xend.XendDomainInfo] DEBUG (XendDomainInfo:1142)
XendDomainInfo.construct: None 0
[2006-04-11 09:37:32 xend.XendDomainInfo] DEBUG (XendDomainInfo:1174)
XendDomainInfo.initDomain: 12 1.0
[2006-04-11 09:37:32 xend] DEBUG (balloon:84) Balloon: free 1505; need 257;
done.
[2006-04-11 09:37:32 xend] INFO (image:135) buildDomain os=linux dom=12 vcpus=1
[2006-04-11 09:37:32 xend] DEBUG (image:173) dom            = 12
[2006-04-11 09:37:32 xend] DEBUG (image:174) image          =
/boot/vmlinuz-2.6.15-1.2054_FC5
[2006-04-11 09:37:32 xend] DEBUG (image:175) store_evtchn   = 1
[2006-04-11 09:37:32 xend] DEBUG (image:176) console_evtchn = 2
[2006-04-11 09:37:32 xend] DEBUG (image:177) cmdline        =  ro selinux=0 3
[2006-04-11 09:37:32 xend] DEBUG (image:178) ramdisk        = 
[2006-04-11 09:37:32 xend] DEBUG (image:179) vcpus          = 1
[2006-04-11 09:37:32 xend] DEBUG (image:180) features       = 
[2006-04-11 09:37:32 xend.XendDomainInfo] ERROR (XendDomainInfo:189) Domain
construction failed
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/xen/xend/XendDomainInfo.py", line 182,
in create
    vm.initDomain()
  File "/usr/lib/python2.4/site-packages/xen/xend/XendDomainInfo.py", line
1209, in initDomain
    channel_details = self.image.createImage()
  File "/usr/lib/python2.4/site-packages/xen/xend/image.py", line 118, in
createImage
    return self.createDomain()
  File "/usr/lib/python2.4/site-packages/xen/xend/image.py", line 137, in
createDomain
    result = self.buildDomain()
  File "/usr/lib/python2.4/site-packages/xen/xend/image.py", line 188, in
buildDomain
    features       = self.features)
error: (22, 'Invalid argument')
[2006-04-11 09:37:32 xend.XendDomainInfo] DEBUG (XendDomainInfo:1290)
XendDomainInfo.destroy: domid=12
[2006-04-11 09:37:32 xend.XendDomainInfo] DEBUG (XendDomainInfo:1298)
XendDomainInfo.destroyDomain(12)
[2006-04-11 09:37:32 xend] ERROR (SrvBase:87) Request create failed.
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/xen/web/SrvBase.py", line 85, in
perform
    return op_method(op, req)
  File "/usr/lib/python2.4/site-packages/xen/xend/server/SrvDomainDir.py", line
82, in op_create
    raise XendError("Error creating domain: " + str(ex))
XendError: Error creating domain: (22, 'Invalid argument')
Comment 3 mikedlr 2006-04-17 13:11:16 CDT
I have created a very similar report in RedHat's bugzilla
https://bugzilla.redhat.com0

turning off selinux in /etc/selinux/config, rebooting a couple of times and
then logging in over ssh instead of the console suddenly made my vm work; at
least for a now.  
Comment 4 mikedlr 2006-04-21 11:39:54 CDT
I'm quite sure that my similar bug is an selinux interaction and that you just
have to have selinux properly off (permissive mode) by editing
/etc/selinux/config.

Joe, can you please confirm that.  If it's so then this should be set to not be
a bug (invalid??).  The problem is in FC 5's SELinux and not in Xen.  
Comment 5 Joe Thykattil 2006-04-21 12:41:17 CDT
Turns out that the error was caused due to attempting to boot a non xenU
kernel...which of course is not an viable option until the hardware enabled,
nod-modified guest OS options become available.

Thanks,

Joe